Perform a Firmware Update or Device Sync - SPOT Trace

AA-00837

Making changes to your device settings will require the synchronization of your device with your SPOT account.  To update or sync the SPOT Trace the SPOT Device Updater software is required.  Please visit the download page by clicking here.

At this time, only Windows and Mac operating systems are supported.


Common Issues

I cannot find the auth code for my Trace

I’m not able to enter my auth code

I’m receiving an error after I click Update Device



Need Help?
Contact Us